import Foundation
let pattern = ##"([a-zA-Z]+|[!@#$%^&*()_=;.?])[0-9]+"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"jkl3242oij92384nji332332!23#900&6382^832983@7729.979797_70979797"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)