use strict;
my $str = 'jkl3242oij92384nji332332!23#900&6382^832983@7729.979797_70979797';
my $regex = qr/([a-zA-Z]+|[!@#$%^&*()_=;.?])[0-9]+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}