using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/folder\/file\.aspx\?(?:\w+(?:=\w+)?&)*options=all";
string input = @"/folder/file.aspx?a&options=all&test=blub";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}