const regex = /\/folder\/file\.aspx\?(?:\w+(?:=\w+)?&)*options=all/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/folder\\\/file\\.aspx\\?(?:\\w+(?:=\\w+)?&)*options=all', '')
const str = `/folder/file.aspx?a&options=all&test=blub`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}