package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/folder\/file\.aspx\?(?:\w+(?:=\w+)?&)*options=all`)
var str = `/folder/file.aspx?a&options=all&test=blub`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}