$re = '/\/folder\/file\.aspx\?(?:\w+(?:=\w+)?&)*options=all/';
$str = '/folder/file.aspx?a&options=all&test=blub';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);