re = /\/folder\/file\.aspx\?(?:\w+(?:=\w+)?&)*options=all/
str = '/folder/file.aspx?a&options=all&test=blub'
# Print the match result
str.match(re) do |match|
puts match.to_s
end