#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^,\n]+,(?:[^,\n]+,?){0,2}$"
Local $sString = "New York, New York, United States" & @CRLF & _
"New York, New York" & @CRLF & _
"New York" & @CRLF & _
"New York, New York, United States,asdsad" & @CRLF & _
"new yorok,asdasd,asddasd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")