package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^,\n]+,(?:[^,\n]+,?){0,2}$`)
var str = `New York, New York, United States
New York, New York
New York
New York, New York, United States,asdsad
new yorok,asdasd,asddasd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}