re = /^[^,\n]+,(?:[^,\n]+,?){0,2}$/m
str = 'New York, New York, United States
New York, New York
New York
New York, New York, United States,asdsad
new yorok,asdasd,asddasd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end