$re = '/^[^,\n]+,(?:[^,\n]+,?){0,2}$/m';
$str = 'New York, New York, United States
New York, New York
New York
New York, New York, United States,asdsad
new yorok,asdasd,asddasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);