const regex = /^[^,\n]+,(?:[^,\n]+,?){0,2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^,\\n]+,(?:[^,\\n]+,?){0,2}$', 'gm')
const str = `New York, New York, United States
New York, New York
New York
New York, New York, United States,asdsad
new yorok,asdasd,asddasd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}