#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\d*(?:9999|0000)$)\d{9}$"
Local $sString = "Match:" & @CRLF & _
"" & @CRLF & _
"123456789" & @CRLF & _
"123459991" & @CRLF & _
"123459990" & @CRLF & _
"" & @CRLF & _
"But not these:" & @CRLF & _
"" & @CRLF & _
"123450000" & @CRLF & _
"123459999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")