const regex = /^(?!\d*(?:9999|0000)$)\d{9}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\d*(?:9999|0000)$)\\d{9}$', 'gm')
const str = `Match:
123456789
123459991
123459990
But not these:
123450000
123459999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}