$re = '/^(?!\d*(?:9999|0000)$)\d{9}$/m';
$str = 'Match:
123456789
123459991
123459990
But not these:
123450000
123459999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);