re = /^(?!\d*(?:9999|0000)$)\d{9}$/m
str = 'Match:
123456789
123459991
123459990
But not these:
123450000
123459999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end