import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\d*(?:9999|0000)$)\\d{9}$";
final String string = "Match:\n\n"
+ "123456789\n"
+ "123459991\n"
+ "123459990\n\n"
+ "But not these:\n\n"
+ "123450000\n"
+ "123459999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}