#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(AB(?:[0-9A-Z]{5}|[0-9]{4}))(?:\s+)"
Local $sString = "foo" & @CRLF & _
"AB0001" & @CRLF & _
"AB0002 foo" & @CRLF & _
"foo AB0003" & @CRLF & _
"foo AB0004A AB0004.1" & @CRLF & _
"AB0005.1 foo AB0005A bar AB0005"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")