$re = '/(AB(?:[0-9A-Z]{5}|[0-9]{4}))(?:\s+)/';
$str = 'foo
AB0001
AB0002 foo
foo AB0003
foo AB0004A AB0004.1
AB0005.1 foo AB0005A bar AB0005';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);