import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(AB(?:[0-9A-Z]{5}|[0-9]{4}))(?:\\s+)";
final String string = "foo\n"
+ "AB0001\n"
+ "AB0002 foo\n"
+ "foo AB0003\n"
+ "foo AB0004A AB0004.1\n"
+ "AB0005.1 foo AB0005A bar AB0005";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}