const regex = /(AB(?:[0-9A-Z]{5}|[0-9]{4}))(?:\s+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(AB(?:[0-9A-Z]{5}|[0-9]{4}))(?:\\s+)', 'g')
const str = `foo
AB0001
AB0002 foo
foo AB0003
foo AB0004A AB0004.1
AB0005.1 foo AB0005A bar AB0005`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}