# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-zA-Z])\?([a-zA-Z])/\1fi\2/g;t' <<< "Eg., \"Okay?\" should be \"Okay?\" and not \"Okayfi\"
but
Modi?es should be Modifies since it has ? in middle"