re = /([a-zA-Z])\?([a-zA-Z])/
str = 'Eg., "Okay?" should be "Okay?" and not "Okayfi"
but
Modi?es should be Modifies since it has ? in middle'
subst = '\\1fi\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result