package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-zA-Z])\?([a-zA-Z])`)
var str = `Eg., "Okay?" should be "Okay?" and not "Okayfi"
but
Modi?es should be Modifies since it has ? in middle`
var substitution = "\1fi\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}