// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-zA-Z])\?([a-zA-Z])").unwrap();
let string = "Eg., \"Okay?\" should be \"Okay?\" and not \"Okayfi\"
but
Modi?es should be Modifies since it has ? in middle";
let substitution = "\\1fi\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}