using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ +(\d)\. button.uuid.* Moved.*$";
string substitution = @"$1";
string input = @"Virtual machine message 43080362:
This virtual machine might have been moved or copied. In order to configure certain management and networking features, VMware ESX needs to know if this virtual machine was moved or copied. If you don't know, answer ""I Copied It"".
0. button.uuid.cancel (Cancel)
1. button.uuid.movedTheVM (I Moved It)
2. button.uuid.copiedTheVM (I Copied It) [default]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}