import Foundation
let pattern = #"^ +(\d)\. button.uuid.* Moved.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Virtual machine message 43080362:
This virtual machine might have been moved or copied. In order to configure certain management and networking features, VMware ESX needs to know if this virtual machine was moved or copied. If you don't know, answer "I Copied It".
0. button.uuid.cancel (Cancel)
1. button.uuid.movedTheVM (I Moved It)
2. button.uuid.copiedTheVM (I Copied It) [default]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)