const regex = /^ +(\d)\. button.uuid.* Moved.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ +(\\d)\\. button.uuid.* Moved.*$', 'gm')
const str = `Virtual machine message 43080362:
This virtual machine might have been moved or copied. In order to configure certain management and networking features, VMware ESX needs to know if this virtual machine was moved or copied. If you don't know, answer "I Copied It".
0. button.uuid.cancel (Cancel)
1. button.uuid.movedTheVM (I Moved It)
2. button.uuid.copiedTheVM (I Copied It) [default]`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);