using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\d+(*SKIP)(*F)|(\d)(?!$)";
string substitution = @"\1 ";
string input = @"
abc $1432 def 123 456";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}