re = /\$\d+(*SKIP)(*F)|(\d)(?!$)/m
str = '
abc $1432 def 123 456'
subst = '\\1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result