const regex = /\$\d+(*SKIP)(*F)|(\d)(?!$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$\\d+(*SKIP)(*F)|(\\d)(?!$)', 'gm')
const str = `
abc \$1432 def 123 456`;
const subst = `\1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);