$re = '/\$\d+(*SKIP)(*F)|(\d)(?!$)/m';
$str = '
abc $1432 def 123 456';
$subst = "\1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;