import re
regex = re.compile(r"\$\d+(*SKIP)(*F)|(\d)(?!$)", flags=re.MULTILINE)
test_str = ("\n\n"
"abc $1432 def 123 456")
subst = "\\1 "
result = regex.sub(subst, test_str)
if result:
print(result)