#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)\w+\.?"
Local $sString = "Osama, bin Laden, bin Mohammed" & @CRLF & _
"Jorge do Pinto da Silva A.B.,John Doe. F. sd." & @CRLF & _
"John Andrew Smith" & @CRLF & _
"Doe, John F." & @CRLF & _
"Döe, Frank;John Adam"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")