$re = '/\w+\.?/u';
$str = 'Osama, bin Laden, bin Mohammed
Jorge do Pinto da Silva A.B.,John Doe. F. sd.
John Andrew Smith
Doe, John F.
Döe, Frank;John Adam';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);