using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+\.?";
string input = @"Osama, bin Laden, bin Mohammed
Jorge do Pinto da Silva A.B.,John Doe. F. sd.
John Andrew Smith
Doe, John F.
Döe, Frank;John Adam";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}