package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+\.?`)
var str = `Osama, bin Laden, bin Mohammed
Jorge do Pinto da Silva A.B.,John Doe. F. sd.
John Andrew Smith
Doe, John F.
Döe, Frank;John Adam`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}