// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)\w+\.?").unwrap();
let string = "Osama, bin Laden, bin Mohammed
Jorge do Pinto da Silva A.B.,John Doe. F. sd.
John Andrew Smith
Doe, John F.
Döe, Frank;John Adam";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}