#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^@].*(\n?\r?)"
Local $sString = "@line 1: text text text " & @CRLF & _
"line 2:" & @CRLF & _
"@line3: text text text" & @CRLF & _
"line 4: The line break after this text should be matched " & @CRLF & _
"line 5: The line break after this text also should be selected " & @CRLF & _
"line 6:" & @CRLF & _
"@line 7: this line break should not be selected" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")