import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^@].*(\\n?\\r?)";
final String string = "@line 1: text text text \n"
+ "line 2:\n"
+ "@line3: text text text\n"
+ "line 4: The line break after this text should be matched \n"
+ "line 5: The line break after this text also should be selected \n"
+ "line 6:\n"
+ "@line 7: this line break should not be selected\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}