package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^@].*(\n?\r?)`)
var str = `@line 1: text text text
line 2:
@line3: text text text
line 4: The line break after this text should be matched
line 5: The line break after this text also should be selected
line 6:
@line 7: this line break should not be selected
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}