re = /^[^@].*(\n?\r?)/m
str = '@line 1: text text text
line 2:
@line3: text text text
line 4: The line break after this text should be matched
line 5: The line break after this text also should be selected
line 6:
@line 7: this line break should not be selected
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end