#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[?<=\s\S](\n\n\n)"
Local $sString = "ильям Шекспир (William Shakespeare) родился 23 апреля 1564 года в Стратфорде-на-Эйвоне, графство Уорикшир в Англии. В приходской" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" книге сохранилась запись о его крещении 26 апреля. Отец, Джон Шекспир, был в Стратфорде видным" & @CRLF & _
"" & @CRLF & _
" человеком (по некоторым данным, он торговал"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")