$re = '/[?<=\s\S](\n\n\n)/m';
$str = 'ильям Шекспир (William Shakespeare) родился 23 апреля 1564 года в Стратфорде-на-Эйвоне, графство Уорикшир в Англии. В приходской
книге сохранилась запись о его крещении 26 апреля. Отец, Джон Шекспир, был в Стратфорде видным
человеком (по некоторым данным, он торговал';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);