import Foundation
let pattern = #"[?<=\s\S](\n\n\n)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ильям Шекспир (William Shakespeare) родился 23 апреля 1564 года в Стратфорде-на-Эйвоне, графство Уорикшир в Англии. В приходской
книге сохранилась запись о его крещении 26 апреля. Отец, Джон Шекспир, был в Стратфорде видным
человеком (по некоторым данным, он торговал
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)