using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[?<=\s\S](\n\n\n)";
string input = @"ильям Шекспир (William Shakespeare) родился 23 апреля 1564 года в Стратфорде-на-Эйвоне, графство Уорикшир в Англии. В приходской
книге сохранилась запись о его крещении 26 апреля. Отец, Джон Шекспир, был в Стратфорде видным
человеком (по некоторым данным, он торговал";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}