package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[?<=\s\S](\n\n\n)`)
var str = `ильям Шекспир (William Shakespeare) родился 23 апреля 1564 года в Стратфорде-на-Эйвоне, графство Уорикшир в Англии. В приходской
книге сохранилась запись о его крещении 26 апреля. Отец, Джон Шекспир, был в Стратфорде видным
человеком (по некоторым данным, он торговал`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}