#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)((?:(?:public|private|protected|static|final|abstract|synchronized|volatile)\s+)*)\s*(\w+)\s*(\w+)\(.*?\)\s*({(?:{[^{}]*(?:{[^{}]*}|.)*?[^{}]*}|.)*?})"
Local $sString = "public static FieldsConfig getFieldsConfig(){" & @CRLF & _
" if(xxx) {" & @CRLF & _
" sssss;" & @CRLF & _
" }" & @CRLF & _
" else {" & @CRLF & _
" xcvxcv;" & @CRLF & _
" if(yyy) {" & @CRLF & _
" Doit();" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" return;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"static void Next() {};" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")