import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:(?:public|private|protected|static|final|abstract|synchronized|volatile)\\s+)*)\\s*(\\w+)\\s*(\\w+)\\(.*?\\)\\s*(\\{(?:\\{[^\\{\\}]*(?:\\{[^\\{\\}]*\\}|.)*?[^\\{\\}]*\\}|.)*?\\})";
final String string = "public static FieldsConfig getFieldsConfig(){\n"
+ " if(xxx) {\n"
+ " sssss;\n"
+ " }\n"
+ " else {\n"
+ " xcvxcv;\n"
+ " if(yyy) {\n"
+ " Doit();\n"
+ " }\n"
+ " }\n"
+ " return;\n"
+ "}\n\n\n"
+ "static void Next() {};\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}