re = /((?:(?:public|private|protected|static|final|abstract|synchronized|volatile)\s+)*)\s*(\w+)\s*(\w+)\(.*?\)\s*({(?:{[^{}]*(?:{[^{}]*}|.)*?[^{}]*}|.)*?})/
str = 'public static FieldsConfig getFieldsConfig(){
if(xxx) {
sssss;
}
else {
xcvxcv;
if(yyy) {
Doit();
}
}
return;
}
static void Next() {};
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end